*.lvm- Einlesefilter

  • Hier steht die aktuelle Version des Einlesefilters für LabVIEW- *.lvm - Dateien in der Version

    LabVIEW_LVM_V1R2.fas


    zum Download zur Verfügung.
    sinnvolle und getestetet Parametierung vom Express-VI(Messwerte in Datei schreiben)



    als Test können z.B: mit

    Code
    1. FASLADEN "*.lvm" , "LabView_LVM_V1R2.FAS"


    alle *.lvm- Dateien des aktuellen Standardverzeichnisses eingelesen werden.


    Bei Problemen oder Wünschen zu diesem Einlesefilter bitte direkt in diesem Forum posten.
    Viel Erfolg und Spaß bei der Verwendung
    FAMOS-Forum TEAM


    Versionshistorie:
    LabVIEW_LVM_V1R2

    • Der xAchsenoffset steht indirekt doppelt in der *.lvm-Datei (im Datum und als X0). Nun wird ausschliesslich das Datum als Triggerungszeitpunkt definiert, da es sonst zu einer Verschiebung auf der xAchse kommt.
    • Ist als Trennzeichen das Komma angewählt, wird nun das Datum trotz "Nachkomma" Sekunden der Variablen richtig zugeordnet

    LabVIEW_LVM_V1R1

    • wenn keine Headerinformationen angegeben sind, wird die Datei in Spaltenstruktur ausgelesen => x-Achse kann mehrfach vorkommen
    • Komma wird als Trennzeichen unterstützt

    LabVIEW_LVM_V1R0

    • Mehrkanaliges auslesen von *.lvm-ASCII- Dateien, die mit dem Express-VI (Messwerte in Datei schreiben) generiert wurden.
    • LabVIEW Measurement Writer Version 0.92
    • Tabulator als Trennzeichen
    • äquidistante Zeitreiheninformationen
    • Headerinformationen sind mindestens einmalig vorhanden

    Dateien

    Die Kontinuität in der Vergangenheit ist die Qualität der Gegenwart und die Sicherheit der Zukunft :whistling:

  • Der Einlesefilter wurde mit Dateien getestet und entwickelt, die mit dem nachfolgenden Blockdiagramm generiert wurden:



    Die Daten, die hieraus resultieren, können bereits optisch im zugehörigen Frontpanel kontrolliert werden.


    diese Daten sehen dann in FAMOS geladen so aus:


    Das *.vi steht hier für weitere Tests und als Konfigurationsbeispiel zur Verfügung.

  • Hallo Famos Freak


    Ich hab mir nun dein Labview VI runtergeladen und eine LVM Datei mit diesem VI erzeugt.


    Die Parameter im VI hab ich so gesetzt wie du angegeben hast.


    Ich hab den Filter in Famos eingebunden und wollte eine LVM-Datei öffnen.


    Folgende Fehlermeldung kommt dann:


    "Die ausgewählte Datei entspricht nicht der Struktur der Writer Version 0.92. Bitte korrigieren"


    Kann mir jemand sagen, was das bedeutet?


    Ist meine Labview Version (8.6) dafür verantwortlich?

  • Hallo


    Ich hab mittlerweile festgestellt, dass der Filter für meine LVM-Datei nicht ganz passt.


    Ich hab z.B. eine andere Version des Labview "Writers" -->Version 2 (Da bringt der Filter schon ne Fehlermeldung)


    Außerdem hab ich eine Zeitspalte in meiner LVM-Datei.


    Leider hab ich mit dem Filter keinerlei Erfahrung :( . Wer kann mir helfen?


    Als Anhang findet ihr meine Einstellungen in Labview, sowie die erzeugte LMV-Datei (hab ich in *.txt umgewandelt)

  • Hallo Chris,


    Bei den Labview Einstellungen solltest du die Option in der x-Spalte: leere Zeitspalte anwählen, dann hast du das Problem der zusätzlichen Zeitspalte nicht mehr.


    Ansonsten, probiere mal aus, ob der Einlesefilter funktioniert, wenn du einfach die neue Versionsbezeichnung, die Labview rausschreibt im Einlesefilter ersetzt: also in der *.fas Datei Writer_Version 0.92 Version 1 mit Writer_Version 2 ersetzen.


    Viel Spass beim Probieren!


    Aber vielleicht gibt es ja auch bald eine aktuelle *.fas Datei für die neueste Labview-Version :?:


    Liebe Grüße
    Sandy

  • Hallo Sandy


    Danke für deine schnelle Antwort. Die Version hab ich auf "2" geändert, so wie du das beschrieben hast. Jetzt bekomm ich keinen Versionsfehler mehr :) .


    Wenn ich die X-Spalte in Labview als leere Spalte definiere, klappt das zwar mit dem Einlesefilter, leider kann ich aber dann den zeitlichen Verlauf meiner Messdaten nicht mehr sehen :( . Und den bräuchte ich für meine Messung. Ich muss wissen zu welcher Zeit mein Messsignal welchen Wert hat.


    Hast du ne Lösung für das Problem?


    LG

  • Hallo zusammen,


    kann die Datei nicht Downloaden


    Bekomme die Fehlermeldung "Der Zutritt zu dieser Seite ist Ihnen leider verwehrt. Sie besitzen nicht die notwendigen Zugriffsrechte, um diese Seite aufrufen zu können."


    Kann mir jemand einen Tip geben, was hier nicht passt.

  • Im Normalfall ist der Status Deiner Benutzeranmeldung das Kriterium, mit dem man hier im Forum auf die unterschiedlichsten Levels zugreifen kann.


    Ich rate mal:
    Entweder hast Du einen NN-Acount als email Adresse angegeben
    oder nicht genügend persönliche Angaben für eine Personenzuordnung gemacht
    oder bist noch als Gast registriert
    oder ...


    somit Benutzerprofil ergänzen und kurze Info an einen Moderator
    viel Spaß

  • Hallo Chris_1982,
    nachfolgend ein temporär angepasstes Beispiel des Einlesefilters auf Deine Daten, wie man sieht, ist es sinnvoll den Einlesefilter mit einer Strukturprüfung zu versehen, da hier von NI verschiedene versionsabhängige Anpassungen vorgenommen wurden
    Die Anwendung diese Einlesefilters führt zu:

    somit viel Spaß und Erfolg bei der Verwendung
    (wenn ich mal Zeit im Überfluß habe wird dieser auch auf einen Versionsstand angehoben oder wenn's Geld bring :whistling: )

    Dateien

    Die Kontinuität in der Vergangenheit ist die Qualität der Gegenwart und die Sicherheit der Zukunft :whistling:

  • Servus^^


    Ich suche genau nach diesem .lvm Importfilter! Jetzt sagt mir aber das FamosForum, ich hätte nicht genügend Zugriffsrechte um den Filter herunterzuladen... seltsam, aber ich komme an den Filter nicht ran. Ich würde mich freuen, wenn den Filter jemand an [...Spamschutz..Du solltest nun die Rechte haben....] senden könnte. Würde mir sehr viel Arbeit und monotones Klicken ersparen.


    Dankeschön, Goran.

  • Hallo,

    ich bin neu hier.

    Habe den Filter erfolgreich runtergeladen und im Debug Modus probiert.

    Funktioniert einwandfrei. Wenn ich aber in FAMOS über das Eingabe Fenster gehe und den Befehl:

    FASLADEN "Messdaten_1.lvm" , "LabView_LVM_V1R2.FAS"

    eingebe bekomme ich folgende Fehlermeldung:

    ---------------------------

    Famos

    ---------------------------

    Fehler beim Öffnen der Konfigurations-Datei (*.fas)!

    ---------------------------

    OK

    ---------------------------


    Jemand einen Tipp für mich ?


    Mfg

    Markus

  • Was passiert, wenn du die FileLoad-Methode anwendest? Auch hier gibst du ja das Einlesefilter an.

    Ansonsten kann es natürlich sein, dass dein Dateiformat nicht dem obigen entspricht und das Einlesefilter deswegen nicht so funktionieren kann.

    Der Beitrag ist ja auch schon 9 Jahre alt. Nicht dass sich da etwas am *.lvm-Format seitens Matlab getan hat.


    Hast du noch Alternativen zu diesem Dateiformat? Also kannst du seitens des Quellprogramms in einem anderen Format speichern, dass (dein) FAMOS eher akzeptiert?


    Allerdings ist es interessant, dass im Debug-Fall es bei dir funktioniert und sonst nicht. :/